45 lines
469 B
Nix
45 lines
469 B
Nix
{
|
|
lib,
|
|
mkShell,
|
|
cargo,
|
|
rustc,
|
|
rustfmt,
|
|
clippy,
|
|
rust,
|
|
|
|
cmake,
|
|
pkg-config,
|
|
|
|
boost,
|
|
sndio,
|
|
libGL,
|
|
pulseaudio,
|
|
pipewire,
|
|
SDL2,
|
|
openal,
|
|
}:
|
|
mkShell {
|
|
packages = [
|
|
rustc
|
|
cargo
|
|
rustfmt
|
|
clippy
|
|
|
|
cmake
|
|
pkg-config
|
|
|
|
boost
|
|
sndio
|
|
pulseaudio
|
|
pipewire
|
|
SDL2
|
|
openal
|
|
];
|
|
|
|
LD_LIBRARY_PATH = "${lib.makeLibraryPath [
|
|
libGL
|
|
]}";
|
|
|
|
RUST_SRC_PATH = "${rust.packages.stable.rustPlatform.rustLibSrc}";
|
|
}
|