29 lines
422 B
Nix
29 lines
422 B
Nix
{
|
|
lib,
|
|
mkShell,
|
|
python3,
|
|
inkscape-with-extensions,
|
|
inkscape-extensions,
|
|
jupyter,
|
|
}:
|
|
mkShell {
|
|
packages =
|
|
[
|
|
(inkscape-with-extensions.override {
|
|
inkscapeExtensions = with inkscape-extensions; [
|
|
inkcut
|
|
axidraw
|
|
];
|
|
})
|
|
python3
|
|
jupyter
|
|
]
|
|
++ (with python3.pkgs; [
|
|
axicli
|
|
drawsvg
|
|
ipython
|
|
pillow
|
|
requests
|
|
]);
|
|
}
|