Add cursed MAX_TOPO_LEVEL patch
This commit is contained in:
parent
b78b8efaac
commit
dccf6842a3
|
@ -21,6 +21,7 @@
|
|||
}) // {
|
||||
overlays.default = final: prev: {
|
||||
jlink = final.callPackage ./packages/jlink { };
|
||||
kernelPatches = final.callPackage ./packages/kernelPatches { };
|
||||
zephyrPackages = final.callPackage ./packages/zephyr { };
|
||||
};
|
||||
};
|
||||
|
|
6
packages/kernelPatches/default.nix
Normal file
6
packages/kernelPatches/default.nix
Normal file
|
@ -0,0 +1,6 @@
|
|||
{ ... }: {
|
||||
increase_max_topo = {
|
||||
name = "increase-max-topo";
|
||||
patch = ./increase-max-topo.patch;
|
||||
};
|
||||
}
|
13
packages/kernelPatches/increase-max-topo.patch
Normal file
13
packages/kernelPatches/increase-max-topo.patch
Normal file
|
@ -0,0 +1,13 @@
|
|||
diff --git a/include/linux/usb/hcd.h b/include/linux/usb/hcd.h
|
||||
index 3dbb42c637c1..8d45c90cee8a 100644
|
||||
--- a/include/linux/usb/hcd.h
|
||||
+++ b/include/linux/usb/hcd.h
|
||||
@@ -26,7 +26,7 @@
|
||||
#include <linux/interrupt.h>
|
||||
#include <linux/idr.h>
|
||||
|
||||
-#define MAX_TOPO_LEVEL 6
|
||||
+#define MAX_TOPO_LEVEL 1022
|
||||
|
||||
/* This file contains declarations of usbcore internals that are mostly
|
||||
* used or exposed by Host Controller Drivers.
|
Loading…
Reference in a new issue